Questions & Answers

2014 Ford Escape won't shut off

+1 vote
I installed a Evo-All and crimestopper RF kit in a 2014 Ford Escape approximately 2 months ago. All has been good, until this morning. Started car with the remote start and it would not shut off. The only way I could turn the car off was to disconnect the power to the Evo-All.  The yellow light was on on the Evo-All before I disconnected the power. Any ideas please. I also installed the wiring harness for easier install.
asked Oct 17, 2014 in Ford by Jeff Patton (440 points)
edited Oct 17, 2014 by Jeff Patton

1 Answer

0 votes
Hi Jeff,

 

The yellow light is on because the ignition was on. I would be curious to know if the car would of stopped if you were to disconnect the RED connector instead of the 4-pin black connector (power).

 

The car staying ON can be an indication of a short somewhere on the ignition wire to 12v.
answered Oct 17, 2014 by Robb (191,570 points)
would I be correct in assuming if I disconnect the red connector if it does this again, if the short is in the Evo it will turn off, if it is in the t-harness it will still run. Thanks for the help
Bingo, you are 100% on the right track.

 
If the relay in the EVO does not close, ignition would stay powered. Therefore the car would not shut down.

Same with a short in the wires. If a solder is poking out of the tape and touching a 12V source, ignition would again, stay on.
Ok I will try that and see what happens, thank you again for the help
Ok, so it stayed running sgain, this time I disconnected the red connector. The vehicle shut off. I had another Evo-all so I set it up for the 2014 escape and installed it. With in an hour the vehicle would not shut off again. Just to be clear, starting the vehicle normally all functions correctly. The only time the vehicle would shut off was when the vehicle was started with the Ed kit and evo -all. Any help would be great, it's not my car so I don't have 24/7 access to the vehicle.  Also I am only using the RF Kit to start the vehicle. The locks are not hooked up due to the ignition key having the door remote all in one.Thank You
Hi Jeff,

 

Please call tech support when you have the vehicle so we can easily troubleshoot it with you. Any representative will be able to help.
...