Questions & Answers

flash link updater

0 votes
Hello Fortin Technical services Representatives,

installed EVO ALL and bought flashlink updater2 to program my EVO device in 2016. Now, I want to update my EVO ALL remote start unit but the FL updater2 could not be connected thru FL Manager. I bought a FL updater4 thru Amazon to use and the Manager detected the FL Updater and the EVO ALL device but when I try ti update, Manager display message: " Device Flash Limit Reached" The current device cannot be flash anymore.

My FL Updater4 Service number: 002505  091741

Please helps

PS. also, please let me know how many time the FL Updater can be used to Update the EVO ALL?

Thanks in advandce,

Minh Le
asked Aug 27 in Chrysler by MINH LE (160 points)

1 Answer

0 votes
Evo modules dated 2016 and older cannot be updated via the flash link. If the manufacture date on the back of your evo refelects these year ranges, this is why it will not allow it to update.
answered Aug 29 by derek (270,220 points)
...