Questions & Answers

2005 Jeep Grand Cherokee Evo-One Keeps running with key removed

0 votes
Issue developed recently. Jeep remote starts just fine. Sometimes it keeps running after the key has been removed. I think this happens when the Jeep has been remote started. When I am done driving and remove the key everything turns off, but the engine continues to run. It looks like there is a solid orange light on the device. If I disconnect the red connector the Jeep shuts off.
asked Jan 29 in Jeep by Kevin Lewis (130 points)

1 Answer

0 votes
Do you press a start button just once for about one to three seconds to start the jeep? If so then you're most probably inadvertently pressing that same button upon removing the key out of the ignition...and if so then you're simply re-engaging the remote start process, which is indicative of certain accessories being turned off - but with the engine left running and also you can still turn on the heat or air conditioner in this mode. When you remote start the vehicle, enter it, put the key into ignition and turn it to the run position and depress the brake, theny the remote running status has been turned off. Now when you put the vehicle into park, take foot off brake, then grab the key and (inadvertently) depress the start (or lock-whichever was programmed to start the vehicle) button, then its possible that the remote status has indeed been initialized before you have even removed the key...or even after you've exited the vehicle and entered your house (or any other place for that matter). So try to make sure not to be pressing any buttons on the key fob when removing from the ignition. Hope this helps.
answered Jul 8 by Marvin Gerald (250 points)
edited Jul 8 by Marvin Gerald
...