Questions & Answers

Check engine light on after remote start, low fuel warning light, AWD malfuction

0 votes

On DEC.8, 2021 I posted my question "H-KEY 2020 TOYOTA RAV4 LE EVO ONE WITH T-HARNESS REMOTE STARTER INSTALLED - SYSTEM MALFUNCTION" and got answer. I did what recommand to do, evnen hardwiring CAN HIGH/LOW  two wires and use RAV4 CAN connector plugged in ECU, no luck.

My rav4 remote start problem more like this after a few weeks oberservation

  • Use OEM remote or RFK442 remote, the low fuel yellow light show up after remote started, When going in the car, key in the key cylinder and turne to ON position, press brake, key taking over. The yellow low fuel light disappear, and fuel display needle moving up to level.
  • After a few times remote starting, when you try another remote starting, the check engine light show up, and screen also shwing "AWD System Malfuntion. 2WD Mode Engaged, Visit you r dealer"

The CHECK ENGINE light was P2067: generic fuel level sensor "B" circuit low. I am wondering that low fuel level sensor B dosen't powered up  when remote started, then ECU set the CHECK  ENGINE light. I reset it by OBDII, but it keep coming. If no remote starting, RAV4 going normal by the OEM key and no warning light.

Is this could be a communication issue between EVO ONE and RAV4 ? The IGNITION signal from EVO ONE should go power up fuel level sensor B when remote starting, but it doesn't. 

Any idea? Could you please look at 2020 RAV4 LE AWD(Canadian version) wiring diagram, see how.

Thanks in advance! 

 

asked 1 week ago in Toyota by Matthew Lee (210 points)

1 Answer

0 votes
Sounds like something isnt properly clipped in or there is a loose pin.

 

You issue sounds like it stems from the install itself.

 

I would remove the t-harness, return vehicle back to stock and see if error messages go away, if they do, you need to go over your work.
answered 1 week ago by Derek (248,530 points)
In my casse, if no remote starting, there is no warning light. Using OEM key starting, everything is normal, RAV4 driving great.

Thanks Derek. I'll try remove T-Harness,
I removed T-Harness, re-connected TPMS and IMI wires for RAV4, no remote starter, back original Toyota RAV4. Driving three rounds in the twon yesterday, no low fuel warning light, no checck engine light, RAV4 going great.

I checked my truck remote starting( AUTOstart starter): the fuel gauge needle moving up to level as soon as remote started, no warning light.

So, Derek, I don't know other 2019+RAV4 LE H-key vehicle having same problem with Fortin remote start? for my case, seems the ignition command from EVO-ONE didn't finish all the work, leave the fuel level sensor B no power(+12V). That's why the warning light came on, gauge needle not moving.

Could you please look at fuel sensor B wiring diagramm, see how it get power.
I have no reports of this issue on any rav4 vehicles at this time.

 

The only other thing I can suggest at this time is to call into technical support to go over your installation with a tech on the phone so see if we can determine any loose, bent pins or possible set up or configuration issues.

 

1-877-336-7797

 

I would suggest having additional parts on hand incase we need to swap our module/harness.

 

Also you shold have access to the flash link updater incase a firmware change is required.

 

Best Regards.
Ok, Derek, I'll call tech support,

Thanks,
...